MacOS LOB apps aren't deployed in Microsoft Intune

Applies to: Microsoft Intune

Symptoms


You add a macOS line-of-business (LOB) app to Microsoft Intune, and then you try to deploy the app to macOS devices. However, the app isn't installed on the targeted devices, and no error messages are shown in Intune.

Cause


The issue occurs if your .pkg package doesn't contain the following information:

  • The package version and CFBundleVersion string in the packageinfo file.
  • The correct install-location in the pkg-info file.

This information is required so that Intune can deploy the app on targeted devices.

To check whether your .pkg package contains the required information, follow these steps:

  1. On a macOS device, use the following IntuneAppUtil command within the Intune App Wrapping Tool for Mac to extract the detected parameters and version for the created .intunemac file:

    IntuneAppUtil -r <filename.intunemac> [-v]

  2. Check whether the Detection.xml file contains the package version. Here is an example of the Detection.xml file:
     
  3. Run the following command to extract the pkg-info file in your .pkg file:

    xar -x -f <.pkg file path> -C <Output folder>

  4. Check whether the output contains CFBundleVersion and install-location. The installation location should be /Applications or its subfolder, as in the following example:
     

Resolution


To fix the issue, contact your app developer to rebuild the .pkg package to include the required information.

For Apple-specific developer documentation, see https://developer.apple.com/.

More information


Currently, support for macOS app deployment is limited to simple .pkg apps that are installed in the /Applications folder and Office 365 apps for macOS.