FIX: BizTalk Server Accelerator for SWIFT - Message Pack 2019 causes MT300 and MT304 Validation rules to fail

Applies to: Microsoft BizTalk Accelerator for SWIFT 2.0 Enterprise EditionMicrosoft BizTalk Accelerator for SWIFT 2.1 Service Pack 1Microsoft BizTalk Accelerator for SWIFT 2.3 Service Pack 1

Symptoms


Consider the following scenario:
  • You use Microsoft BizTalk Server Accelerator for SWIFT - Message Pack 2019.
  • You use MT300 or MT304 Swift messages in your BizTalk application.
In this scenario, you notice that the Network Rule T78 Policy may be violated unless allthe codes are present. This is because Swift has changed the validation rules for MT300 and MT304 in Message Pack 2019 with a "one or more of the following codes must be used" message.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. 

Resolution


The fix for this problem is available in the following update from the Microsoft Download Center:

References


For information about the service packs and cumulative update listfor BizTalk Server, see the following article in the Microsoft Knowledge Base:

2555976 Service pack and cumulative updatelist for BizTalk Server

For more information about BizTalk Server hotfixes, see thefollowing article in the Microsoft Knowledge Base:

2003907 Information about BizTalkhotfixes and Cumulative Update support