Security Only Update for .NET Framework 4.8 for Windows 8.1 and Windows Server 2012 R2 (KB4576489)

Applies to: .NET Framework

Summary


ClickOnce will no longer download applications from untrusted servers which use NTLM authentication, but, instead, will fail with “Authentication failed”. Sites in the Local Intranet and Trusted sites zones will continue to authenticate as before.

Important

  • As a reminder to advanced IT administrators, updates to .NET Framework 3.5 for Windows 8.1 and Windows Server 2012 R2 should only be applied on systems where .NET Framework 3.5 is present and enabled. Customers who attempt to pre-install updates to .NET Framework 3.5 to offline images that do not contain the .NET Framework 3.5 product enabled will expose these systems to failures to enable .NET Framework 3.5 after the systems are online. For more extensive information about deploying .NET Framework 3.5, see Microsoft .NET Framework 3.5 Deployment Considerations.
  • All updates for Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2 require that update KB 2919355 is installed. We recommend that you install update KB 2919355 on your Windows 8.1-based, Windows RT 8.1-based, or Windows Server 2012 R2-based computer so that you receive updates in the future.
  • If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update. For more information, see Add language packs to Windows.

How to obtain and install the update


Before installing this update

Prerequisite:

To apply this update, you must have .NET Framework 4.8 installed.

Install this update

Release Channel Available Next Step
Microsoft Update Catalog Yes To get the standalone package for this update, go to the Microsoft Update Catalog website.
Windows Server Update Services (WSUS) Yes

This update will automatically sync with WSUS if you configure Products and Classifications as follows:

Product:Windows 8.1 and Windows Server 2012 R2

Classification: Security Updates

Prerequisites

To apply this update, you must have .NET Framework 4.8 installed.

Restart requirement

You must restart the computer after you apply this update if any affected files are being used. We recommend that you exit all .NET Framework-based applications before you apply this update.

Update deployment information

For deployment details for this security update, go to the following article in the Microsoft Knowledge Base:

20200908 Security update deployment information: September 8, 2020

Update removal information

Note We do not recommend that you remove any security update. To remove this update, use the Programs and Features item in Control Panel.

Update restart information

This update does not require a system restart after you apply it unless files that are being updated are locked or are being used.

File information



File information
The English (United States) version of this software update installs files that have the attributes that are listed in the following tables.

Windows 8.1, Windows RT 8.1 and Windows Server 2012 R2 file information

Information about protection and security