How to print the Payables Management distribution account by using the "Check with Stub on Top" format or the "Check with Stub on Bottom" format in Microsoft Dynamics GP


INTRODUCTION


This article describes how to print the Payables Management (PM) distribution account by using the "Check with Stub on Top" format or by using the "Check with Stub on Bottom" format in Microsoft Dynamics GP and in Microsoft Business Solutions - Great Plains 8.0.

MORE INFORMATION


Step 1: Start Report Writer

 

Microsoft Dynamics GP 10.0

On the Microsoft Dynamics GP menu, point to Tools , point to Customize , click Report Writer , and then click Microsoft Dynamics GP in the Product list.

 

Microsoft Dynamics GP 9.0 and Microsoft Business Solutions - Great Plains 8.0

On the Tools menu, point to Customize , click Report Writer , and then click Great Plains in the Product list.

 

Step 2: Create the table relationship

1. On the toolbar, click Tables .
2. In the Table window, click the PM_Payment_Apply_WORK table in the list, and then click Open .
3. In the Table Definition window, click Relationships , and then click New .
4. In the Table Relationship Definition window, click the ellipsis button ( ... ) next to the Secondary Table box.
5. In the Relationship Table Lookup window, click the PM Distribution WORK OPEN table, and then click OK .
6. In the Secondary Table Key list, click PM_Distribution_WORK_OPEN_Key_1 .
7. In the Primary Table list, click Apply TO Voucher Number .
8. In the Secondary Table list, click Voucher Number . This is the only field that is used in the link.
9. Click OK to close the Table Relationship Definition window.
10. Click OK to close the Table Definition window.

Step 3: Add the Account Number field to the report layout

1. On the toolbar, click Reports .
2. In the Report Writer window, click Check with Stub on Top or Check with Stub on Bottom in the Original Reports list, and then click Insert .
3. In the Modified Reports list, click Check with Stub on Top or Check with Stub on Bottom , and then click Open .
4. In the Report Definition window, click Tables .
5. In the Report Table Relationships window, click PM Payment Apply To Work File* , and then click New .
6. In the Related Tables window, click PM Distribution WORK OPEN* , and then click OK to close the window.
7. In the Report Table Relationships window, click PM Distribution WORK OPEN* , and then click New .
8. In the Related Tables window, click Account Master , and then click OK .
9. In the Report Table Relationships window, click Close .
10. In the Report Definition window, click the Layout button. The Report Layout window opens.
11. On the Layout tab in the Toolbox window, drag the Account Number field from the Account Master table into the Body (B) section of the report. You will have to rearrange or remove some existing fields in the Body (B) to make room for the new field.

Note If you change the size of the body of the report, see the following article in the Microsoft Knowledge Base to make sure that the size of the check is compatible:

856504 Check field sizes in Report Writer

12. Close the Report Layout window, and then click Save when you are prompted to save the changes to the report layout.

Step 4: Create the report restrictions

To print the Payables Management distribution account by using the "Check with Stub on Top" format or the "Check with Stub on Bottom" format, you must create two restrictions.

To create the first restriction, follow these steps:
1. In the Report Definition window, click Restrictions .
2. In the Report Restrictions window, click New .
3. In the Report Restriction Definition window, type a name for the restriction in the Restriction Name box. For example, type First .
4. In the Report Table box, click PM Distribution WORK OPEN .
5. In the Table Fields box, click Voucher Number .
6. Click Add Field .
7. In the Operators box, click the equal sign ( = ).
8. Click Add Field under Fields . This creates the following restriction expression:

PM_Distribution_WORK_OPEN.Voucher Number= PM_Distribution_WORK_OPEN.Voucher Number

9. Click OK .
To create the second restriction, follow these steps:
1. In the Report Definition window, click Restrictions .
2. In the Report Restrictions window, click New .
3. In the Report Restriction Definition window, type a name for the restriction in the Restriction Name box. For example, type Second .
4. In the Report Table box, click Account Master .
5. In the Table Fields box, click Account Category Number .
6. Click Add Field .
7. In the Operators box, click the not-equal sign ( <> ).
8. In the Type box, click Integer .
9. In the Constant box, type 1 .
10. Click Add Constant . This creates the following restriction expression:

GL_Account_MSTR.Account Category Number <> 1

11. Click OK .

Step 5: Save the changes to the report, and then exit Report Writer

1. On the File menu, click Microsoft Dynamics GP .
2. Click Save when you are prompted to save the changes to the report layout.
3. Click Save when you are prompted to save the changes to the modified report.
4. Exit Report Writer.

Notes

• This prints only the Payables side of the distribution.
• This works only with Payables Computer Checks. This does not work for checks that are printed dynamically.
• This works only if the check is paying 12 or fewer vouchers. If more than 12 vouchers are paid, a remittance form prints. This is a separate report in Report Writer. If a check is printed with more than 12 vouchers, check alignment may be affected.



     

Step 6: Assign security permissions to the modified report

To assign security permissions to the modified report, use one of the following methods.

 

Method 1: Use security in Microsoft Dynamics GP 10.0

1. On the Microsoft Dynamics GP menu, point to Tools , point to Setup , point to System , and then click Alternate/Modified Forms and Reports .
2. In the ID box, type the ID that is associated with the user who will print this modified report.
3. In the Product box, click Microsoft Dynamics GP .
4. In the Type box, click Reports .
5. Expand Purchasing .
6. Expand the folder for the report that you modified.
7. Click Microsoft Dynamics GP (Modified) .
8. Click Save .
9. On the Microsoft Dynamics GP menu, point to Tools , point to Setup , point to System , and then click User Security .
10. In the User box, click a user ID.
11. In the Company box, click a company.
12. In the Alternate/Modified Forms and Reports ID list, click the ID that you typed in step 2.

Method 2: Use the Advanced Security tool in Microsoft Dynamics GP 9.0 and in Microsoft Business Solutions - Great Plains 8.0

1. On the Tools menu, point to Setup , point to System , and then click Advanced Security .
2. If you are prompted for a password, type the system password in the Please Enter Password box, and then click OK .
3. In the Advanced Security window, click View , and then click By Alternate, Modified and Custom .
4. Do one of the following: • In Microsoft Dynamics GP 9.0, expand Microsoft Dynamics GP .
• In Microsoft Business Solutions - Great Plains 8.0, expand Great Plains .


     
5. Expand Reports , expand Sales , and then expand the report that you modified.
6. Do one of the following: • In Microsoft Dynamics GP 9.0, click Microsoft Dynamics GP (Modified) .
• In Microsoft Business Solutions - Great Plains 8.0, click Great Plains (Modified) .


     
7. Click Apply , and then click OK .

Note By default, when you start the Advanced Security tool, the current user and the current company are selected. Any changes that you make affect the current user and the current company. However, you can select additional users in the Users area of the Advanced Security window. You can select additional companies in the Company Name area of the Advanced Security window.

 

Method 3: Use the Standard Security tool in Microsoft Dynamics GP 9.0 and Microsoft Business Solutions - Great Plains 8.0

1. On the Tools menu, point to Setup , point to System , and then click Security .
2. If you are prompted for a password, type the system password in the Please Enter Password box, and then click OK .
3. In the User ID box click the ID of the user who you want to have access to the modified report.
4. In the Type box, click Modified Reports .
5. In the Series box, click Purchasing .
6. In the Access List box, double-click the report that you modified, and then click OK .

 


     

NOTES


• An asterisk (*) appears next to the report name.
• The report cannot remove the voids from the total if the follow conditions are true:

    •The document is voicded by using a date that differs from the original document date.

    •The report was printed by using a date that is earlier than the voided date.