How to print the notes that are attached in the Payables Transaction Entry window in the Check Remittance report in Microsoft Dynamics GP


INTRODUCTION


This article describes how to print the notes that are attached in the Payables Transaction Entry window in the Check Remittance report in Microsoft Dynamics GP and in Microsoft Business Solutions - Great Plains.

Note All the invoices that the Check Remittance report is printed for must have a note attached. The note attached can be an actual note or only a space entered.

MORE INFORMATION


Note Users who want to follow these steps must have access to Report Writer in Microsoft Dynamics GP or in Microsoft Business Solutions - Great Plains.

Open the report in Report Writer

1.

Use the appropriate method:

• In Microsoft Dynamics GP 10.0, point to Tools on the Microsoft Dynamics GP menu, point to Customize , and then click Report Writer .
• In Microsoft Dynamics GP 9.0 or in Microsoft Business Solutions – Great Plains, point to Customize on the Tools menu, and then click Report Writer .



     
2. In Report Writer, click Tables , and then click Tables .
3. In the Tables window, click the PM_Payment_Apply_WORK table, and then click Open .
4. In the Table Definition window, click Relationships .
5. In the Table Relationship window, click New .
6. In the Table Relationship Definition window, click the ellipsis button (...) to the left of the Secondary Table field.
7. In the Relationship Table Lookup window, click the PM Transaction OPEN File table, and then click OK .
8. In the Secondary Table Key field, select PM_Transaction_OPEN_Key 2 .
9. In the Primary Table list, select the following fields in the following order, and then click OK :
a. Apply To Document Type
b. Voucher Number
10. Close the Table Relationship window.
11. Click OK to close the Table Definition window, and then click Save if you are prompted to save the changes.
12. In the Tables window, click the PM_Transaction_OPEN table, and then click Open .
13. In the Table Relationship window, click Relationships .
14. In the Table Relationship window, click New .
15. In the Table Relationship Definition window, click the ellipsis button (...) to the left of the Secondary Table field.
16. In the Relationship Table Lookup window, click the Record Notes Master table, and then click OK .
17. In the Secondary Table Key field, select SY_Record_Notes_MSTR_Key_1 .
18. In the Primary Table list, click Note Index , and then click OK .
19. Close the Table Relationship window.
20. Click OK to close the Table Definition window, and then click Save if you are prompted to save the changes.
21. Close the Tables window.
22. In Report Writer, click Reports .
23. In the Original Reports section, click the Check Remittance report, and then click Insert .
24. In the Modified Reports section, click the Check Remittance report, and then click Open .

Add the new table relationship

1. In the Report Definition window, click Tables .
2. In the Report Table Relationships window, click the PM Payment Apply To Work File table, and then click New .
3. In the Related Tables window, click the PM Transaction OPEN File table, and then click OK .
4. In the Report Table Relationships window, click the PM Transaction OPEN File table, and then click New .
5. In the Related Tables window, click the Record Notes Master table, and then click OK .
6. Click Close to close the Report Table Relationships window.
7. In the Report Definition window, click Layout .

Add the Text field in the body of the report layout

1. In the Toolbox window, click Record Notes Master in the list.
2. Scroll down the window, click Text Field , and then drag it into the B section on the report.

Note The B section is the Body section.
3. In the Report Layout window, click the Text Field field that was put on the report.
4. Expand the field to be large enough to contain the note that you entered in the Payables Transaction Entry window.

Save the modified report, and then exit Report Writer

1. Close the Report Layout window. Click Save when you are prompted to save the changes to this report layout.
2. In the Report Definition window, click OK .
3.

Use the appropriate method:

• In Microsoft Dynamics GP, click Microsoft Dynamics GP on the File menu.
• In Microsoft Business Solutions - Great Plains 8.0, click Microsoft Business Solutions - Great Plains on the File menu.



     

Assign security permissions to the modified report

Microsoft Dynamics GP 9.0 and Microsoft Business Solutions – Great Plains 8.0

Method 1: Use the Advanced Security tool

1. On the Tools menu, point to Setup , point to System , and then click Advanced Security .
2. If you are prompted, type the system password in the Please Enter Password box, and then click OK .
3. In the Advanced Security window, click View , and then click By Alternate, Modified and Custom .
4.

Use the appropriate method:

• In Microsoft Dynamics GP 9.0, expand Microsoft Dynamics GP .
• In Microsoft Business Solutions - Great Plains 8.0, expand Great Plains .



     
5. Expand Reports , expand Purchasing , and then expand the report that you modified.
6.

Use the appropriate method:

• In Microsoft Dynamics GP 9.0, click to select the Microsoft Dynamics GP (Modified) option.
• In Microsoft Business Solutions - Great Plains 8.0, click to select the Great Plains (Modified) option.



     
7. Click Apply , and then click OK .
Note By default, the current user and the current company are selected when you start the Advanced Security tool. Any changes that you make affect the current user and the current company. However, you can select additional users in the Users area of the Advanced Security window. You can select additional companies in the Company Name area of the Advanced Security window.

Method 2: Use the Standard Security tool

1. On the Tools menu, point to Setup , point to System , and then click Security .
2. If you are prompted, type the system password in the Please Enter Password box, and then click OK .
3. In the User ID list, click the ID of the user who will print this modified report.
4. In the Type list, click Modified Reports .
5. In the Series list, click Purchasing .
6. In the Access List box, double-click the report that you modified, and then click OK .

Note An asterisk appears next to the report name.

Microsoft Dynamics GP 10.0

1. On the Microsoft Dynamics GP menu, point to Tools , point to Setup , point to System , and then click Alternate/Modified Forms and Reports .
2. If you are prompted, type the system password in the Please Enter Password box, and then click OK .
3. In the ID box, type the Alternative/Modified Forms and Reports ID that is associated with the user ID that will print this modified report.
4. In the Product list, click Microsoft Dynamics GP .
5. In the Type list, click Reports .
6. Expand the Purchasing folder.
7. Expand the folder of the report that you modified.
8. Click to select the Microsoft Dynamics GP (Modified) option.
9. Click Save .
10. On the Microsoft Dynamics GP menu, point to Tools , point to Setup , point to System , and then click User Security .
11. In the User list, click a user ID.
12. In the Company list, click a company.
13. In the Alternate/Modified Forms and Reports ID list, click the ID from step 3.

APPLIES TO:


Microsoft Dynamics GP 10.0
Microsoft Dynamics GP 9.0
Microsoft Business Solutions–Great Plains 8.0
Payables Management