You receive an "Error 9060" message when you generate a report in FRx

Microsoft Business Solutions-Axapta 3.0 is now part of Microsoft Dynamics AX 3.0. All references to Microsoft Business Solutions-Axapta and Microsoft Axapta pertain to Microsoft Dynamics AX.

Symptoms

When you generate a report in Microsoft FRx Reporter 6.7, you may receive an "Error 9060" error message that is similar to one of the following messages:
Error Loading Columns for Printing
Error in frxxml Module During the Parsexml Procedure
Error 9060 During the CreateZipFile Procedure
FRxXMLReportheaderfile During the Build XML Procedure

Cause

The problem may occur because Microsoft XML components are missing. Other factors may also cause this problem.


To have us fix this problem for you, go to the "Fix it for me" section. If you would rather fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.





Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

Let me fix it myself

To troubleshoot this problem, follow these steps:
  1. Verify that the .dll files in Microsoft FRx are registered. If the files are unregistered, use an Automated Solution to register the .dll files. For more information about the Automated Solution to register the Microsoft FRx .dll files, visit the following Microsoft Web site:
  2. Verify that all computers that are running FRx Reporter 6.7 have the following software:
    • Microsoft Internet Explorer 6.0 with Service Pack 1 (SP1)
    • XML 3.0 SP5 and XML 4.0 SP2
    To determine the XML version, follow these steps:
    1. Download the Xmlversiontext.exe file from the Microsoft Download Center.

      For more information, click the following article number to view the article in the Microsoft Knowledge Base:

      278674 Determine the version of MSXML parser installed on a computer

    2. Double-click the file, accept the license agreement, and then extract the files.
    3. Locate the extracted files, right-click the Xmlversiontext.ocx file, and then click Open With.
    4. Locate the System32 folder, and then click the Regsvr32.exe file. The Xmlversiontext.ocx file will register.
    5. Double-click the Xmlversiontext.htm file to determine what versions of XML are installed.

  3. If XML 3.0 SP4 is not installed, download and then install XML 3.0 Service Pack 7 (SP7) or a later version.

    The following file is available for download from the Microsoft Download Center:


    Download Download the package now.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    119591 How to obtain Microsoft support files from online services

    Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.


    Note The file is Msxml3usa.msi.
  4. If XML 4.0 SP2 is not installed, download and then install XML 4.0 SP2 from the Microsoft Download Center.

    The following file is available for download from the Microsoft Download Center:

    Download Download the package now.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    119591 How to obtain Microsoft support files from online services

    Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

    Note The file is Msxml.msi.
  5. If your report is being generated to the DrillDown Viewer, verify that the file name extension is .frd instead of .frv.
  6. Determine whether the Exception Report options are selected in the catalog under the Advanced tab in Report Options. If these options are selected, clear them, and then generate the report again.

  7. Examine the permissions for the Hkey_Classes_Root\TypeLib registry subkey. All FRx Reporter users must have full control permissions for this subkey. To examine these permissions, follow these steps:
    1. Start Registry Editor.
    2. Locate and then right-click the Hkey_Classes_Root\TypeLib registry subkey.
    3. Click Permissions, click the Advanced tab, and then verify that all users have full control permissions for this subkey.
    4. Click the Owner tab, and then verify that there is a current owner listed.
  8. Register the important .dll files and the supplemental files in Microsoft FRx. To do this, follow these steps:
    1. Exit Microsoft FRx.
    2. Right-click Start, and then click Explore.
    3. Locate and then open the Microsoft FRx code folder.
    4. Double-click the FRxReg67.cmd file.
    5. Double-click the FRxReg.exe file.
    6. Log on to Microsoft FRx, and then generate the report.

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Article ID: 894338 - Last Review: 28 Jun 2011 - Revision: 1

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