Reliability improvements for Remote Desktop Session Host and RemoteApp

Symptoms

When you use Remote Desktop Session Host or RemoteApp in Windows 8.1, Windows Server 2012 R2, Windows 8, or Windows Server 2012, you experience one of the following reliability issues:
  • The Remote Desktop Service crashes.
  • RemoteApp sessions frequently either stop unexpectedly or become wedged in an unusable state if a client does not cleanly disconnect.
  • Idle sessions last longer than the idle time-out when automatic reconnections occur.

Cause

This problem occurs because of an issue in Remote Desktop Session Host and RemoteApp.

Resolution

Update information

How to obtain this update

Windows Update
This update is available from Windows Update.
Microsoft Download Center
The following files are available for download from the Microsoft Download Center:
Operating systemUpdate
All supported x86-based versions of Windows 8.1Download Download the package now.
All supported x64-based versions of Windows 8.1Download Download the package now.
All supported x64-based versions of Windows Server 2012 R2Download Download the package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
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Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows 8.1 or Windows Server 2012 R2 installed.

Additionally, you must first install update 2919355 in Windows 8.1 or Windows Server 2012 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.
Properties

Article ID: 2959626 - Last Review: 14 Apr 2015 - Revision: 1

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