The email message "Your mailbox is now connected to Dynamics 365" cannot be sent because the mailbox [Mailbox Name] is deactivated or disabled for outgoing email

Applies to: Dynamics 365

Symptom


After you click the Test & Enable Mailbox button in Dynamics 365, the tests fails and the following alert is logged:

"The email message "Your mailbox is now connected to Dynamics 365" cannot be sent because the mailbox [Mailbox Name] is deactivated or disabled for outgoing email.

Email Server Error Code: MailboxDisabled"

Cause


This error occurs if the mailbox is deactivated and the status is now Inactive.

A mailbox could have been deactivated by someone clicking the Deactivate button. If this is a user mailbox, the mailbox could have been deactivated automatically if the regarding user was deactivated. For example: If you remove a user's Dynamics 365 license, the user will be deactivated and also their mailbox record.

Resolution


  1. Click the Activate button on the mailbox record and verify the status shown in the footer of the page shows as Active.
  2. Click the Test & Enable Mailbox button.
  3. If the tests do not succeed, review the alerts that appear.