Email fail to synchronize to Dynamics 365 when encoded with PEC

Applies to: Dynamics CRM

Introduction


What are PEC emails?

PEC emails are certified emails which are used in some countries and they have the same legal validity as registered emails (s/mime).

S/MIME (Secure/Multipurpose Internet Mail Extensions) is a widely accepted method, or more precisely a protocol, for sending digitally signed and encrypted messages.

S/MIME allows you to encrypt emails and digitally sign them.

Symptom


PEC Emails are not getting synchronized with Server Side Synchronization or Email Router.

Cause


Server Side Synchronization and Email Router use Exchange Web Services to connect to an Exchange Server.

PEC and RFC6109 do not use APIs via REST or SOAP, as such Server Side Synchronization and Email Router won't be able to Synchronize these emails properly.

Resolution


When an email is encrypted, it creates a token which is sent to the recipient of that email.

This 1 to 1 relationship makes is possible for a user to send an email to another user and be encrypted.

What happens when an encrypted email is sent is:

As Dynamics is a third party application, when it tries to access the email it will only get this email in an encrypted state.

As the token won’t exist in Dynamics 365, the email will not be decrypted.

• A unique cipher encrypts an email message.

• The email is encoded into ciphertext.

• Email is sent and received.

• Receiver enters a cipher key to decode the message.

PEC and RFC6109 do not use APIs via REST or SOAP, as such Server Side Synchronization and Email Router does not Support this email type for synchronization. 

In order to have this email synchronized with you Dynamics 365 Organization, you will have to remove the encryption from the email, this can be achieved by forwarding the email.