"Dynamics 365 App for Outlook didn't load completely" error occurs in Dynamics 365 App for Outlook.

Applies to: Dynamics 365 Customer Engagement Online

Symptom


When attempting to use the Dynamics 365 App for Outlook, you see the following error:

"Dynamics 365 App for Outlook didn't load completely. Please ensure you are connected to internet and restart the add-in."

If you click the "Show more" link, the additional details includes the following error:

"Error: window.Office not available"

Cause


While loading Dynamics 365 App for Outlook, external script office.js might fail to load. Because office.js is a required dependency, Dynamics 365 App for Outlook cannot start and will show an error.

Resolution


  1. Verify your computer has a connection to the Internet.
  2. If you are using Outlook desktop app follow this guide to ensure that you online https://support.office.com/article/switch-from-working-offline-to-online-2460e4a8-16c7-47fc-b204-b1549275aac9
  3. Reload Dynamics 365 App for Outlook.