Error message when you try to print a modified copy of a modified report: "Report not found, problem starting up report"


SYMPTOMS


Consider the following scenario:

• You modify a report.
• You make a copy of the modified report and then modify the copy. That is, you do not modify the original but instead make a copy of the modified copy.
• You delete the original modified report and then try to print the modified copy of the modified report.



     
In this scenario, you receive the following error message:

Report not found, problem starting up report.

CAUSE


Cause 1

This problem occurs for one of the following reasons:

• The report does not exist.
• The report is corrupted.


     


To resolve this problem, see "Resolution 1" in the Resolution area.

 

Cause 2

This problem occurs for one of the following reasons:

• The Reports.dic file was renamed.
• The Reports.dic file was deleted.


     
To resolve this problem, see "Resolution 2" in the Resolution area.

       

       

    RESOLUTION


    Resolution 1

    To resolve this problem, follow these steps, depending on the version of Microsoft Dynamics that you have installed.

    Microsoft Dynamics 10.0

    1. Export the report to a package file. To do this, follow these steps:
    a. Start Microsoft Dynamics GP 10.0.
    b. Click Microsoft Dynamics GP , click Tools , click Customize , and then click Customization Maintenance .
    c. Click to select the report, and then click Export .
    2. Delete the modified report. To do this, follow these steps:
    a. Click Microsoft Dynamics GP , click Tools , click Customize , and then click Report Writer .
    b. Click Microsoft Dynamics GP , and then click OK .
    c. In Report Writer, click Reports , click the modified report, and then click Delete .
    3. Import the report package that you created. To do this, follow these steps:
    a. Click Microsoft Dynamics GP , click Tools , click Customize , and then click Customization Maintenance .
    b. Click Browse , locate and then select the package file that you created in step 1, and then click OK .

    Microsoft Dynamics GP 9.0 or Microsoft Business Solutions – Great Plains 8.0

    1. Export the report to a package file. To do this, follow these steps:
    a. Start Microsoft Dynamics GP 9.0 or Microsoft Business Solutions – Great Plains 8.0.
    b. Click Tools , Click Customize , and then click Customization Maintenance .
    c. Click to select the report, and then click Export .
    2. Delete the modified report. To do this, follow these steps:
    a. Click Tools , click Customize , and then click Report Writer .
    b.

    Take one of the following actions, as appropriate for your situation:

    • In Microsoft Dynamics GP 9.0, Click Microsoft Dynamics GP , and then click OK .
    • In Microsoft Business Solutions – Great Plains 8.0, click Great Plains , and then click OK .



       
    c. In Report Writer, click Reports , click the modified report, and then click Delete .
    3. Import the report package that you created. To do this, follow these steps:
    a. Click Tools , Click Customize , and then click Customization Maintenance .
    b. Click Import .
    c. Click Browse , locate and select the package file that you created in step 1, and then click OK .

    Resolution 2

    To resolve this problem, follow these steps:
    1. Locate the Reports.dic file. To do this, follow these steps:
    a.

    Take one of the following actions, as appropriate for your situation:

    • In Microsoft Dynamics GP 10.0, point to Tools . On the Microsoft Dynamics GP menu, point to Setup , point to System , and then click Edit Launch File .
    • In Microsoft Dynamics GP 9.0 and earlier versions, point to Setup . On the Tools menu, point to System , and then click Edit Launch File .



       
    b. If you are prompted for a password, type the system password.
    c.

    Take one of the following actions, as appropriate for your situation:

    • In Microsoft Dynamics GP, click Microsoft Dynamics GP in the Edit Launch File window.
    • In Microsoft Business Solutions - Great Plains 8.0, click Great Plains in the Edit Launch File window.



       
    d. Note the path that is displayed in the Reports field.
    e. Click OK to close the Edit Launch File window.
    2. Determine whether the Reports.dic file exists in the location that is specified in step 1d.
    3. If the Reports.dic file does not exist in the location that is specified in step 1d, restore the file from a backup.