Error message: "Class not registered" when you update PowerPivot data

Symptoms

Consider the following scenario:
  • You open a Microsoft PowerPivot workbook that is authored on a different computer on your system.
  • In the PowerPivot window, you try to update the data with the most current data from the back-end server by using the Refresh All option in theRefresh menu. Or, you try to import data by using one of the connections under theExisting Connection option in the Design tab.

In this scenario, you may receive an error message that resembles the following:

The provider <Provider name> is not registered.
The following system error occurred: Class not registered  A connection could not be made to the data source with the DataSourceID of <data source id>', Name of <data source name>. An error occurred while processing the <table name>. The provider <Provider name> is not registered.
The operation has been cancelled.

Note The error may be repeated for each connection that fails.

Cause

The issue occurs when the provider that is defined for the data connection for PowerPivot data does not exist on your system.

This behavior is by design.

Resolution

To resolve the problem, Use one of the following procedures.

Procedure 1: Configure the failing connection to use a different and compatible provider that exists on your system

To do this, follow these steps:

  1. In the Power Pivot Window, click theDesign tab in the ribbon menu.
  2. ClickExisting Connections.
  3. From the list of available connections, click the connection that is failing, and then clickEdit.
  4. In theEdit Connection window, click Advanced.
  5. In theSet Advanced Properties area, change the Provider value to a different and compatible provider, and then update the data.

For example, if the connection is configured to use SQLNCLI10 (SQL Native Client 10 Provider), and if SQL Native client is not installed on your system, change the provider to SQLOLEDB, and then update the data in the workbook.

Procedure 2: Install the provider

  1. Identify the provider that is used for the failing connection. To do this, use the information in the error message or the steps that are documented in Procedure 1 to identify the provider.
  2. Install that provider on your system by using the installation media or by downloading the provider from the Internet.

More Information

You may also see a similar error message when you use a 32-bit system to work with a workbook that was developed on a 64-bit system. And, there is no 32-bit provider that is available for one or more of the connections that are defined in your workbook, or the 32-bit provider is not installed on your system, or vice-versa.
Properties

Article ID: 2022518 - Last Review: Feb 18, 2014 - Revision: 1

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