The new printer status is "Offline" after you delete a print queue and then restart a Windows-based computer


Symptoms


Consider the following scenario:

  • You delete a print queue while it is in an Offline status.
  • You add a new print queue that has the same name as the old print queue.
  • You restart the computer.

In this scenario, the status of the new print queue is displayed as Offline.

Cause


This problem occurs if the computer has the following registry value configured when you set the printer to the Offline status:

Key: HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<print queue name>
Value: PrinterOnLine
Data: 0

However, this value is not deleted by the Localspl.dll file when the print queue is deleted. Therefore, when you add a print queue that has the same name as the old print queue, the new printer queue inherits the Offline status of the deleted print queue.

Resolution


To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Download button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Notes
  • Run this package after you delete a print queue but before you add a new print queue of the same name.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
Then, go to the "Did this fix the problem?" section.


 

Let me fix it myself

To resolve this issue, right-click the new print queue in the Printers and Faxes tool, and then clear the Use Printer Offline setting. This resets the registry key to the correct value. Alternatively, you can delete the registry key that is mentioned in the "Cause" section after you delete a print queue but before you add a new print queue of the same name.


Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.