Symptoms
Consider the following scenario:
- User A is a Microsoft Exchange Server 2007 Unified Messaging user.
- An external caller calls User A and leaves a voice mail.
- The caller-id of the external caller contains a wildcard (*) character.
- When User A logs into Outlook Voice Access and then tries to play the voice mail, there is nothing. Or, User A receives the following error message:Message cannot be read.
- User A cannot play the voice mail by using the Play on Phone feature in Microsoft Office Outlook.
- User A cannot press the Play button of Windows Media Player for the voice mail in Outlook and in Outlook Web Access.
Cause
This problem occurs because the caller-id of the external caller is used for the voice mail file name. However, wildcard characters are invalid for file names.
Resolution
To resolve this problem, install the following update rollup:
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.