You cannot install Office Communications Server 2007 R2, Unified Communications Managed API 2.0 Core Redist or Office Communications Server 2007, Unified Communications Managed API v1.0 Redist

Symptoms

You cannot install Microsoft Office Communications Server 2007 R2, Microsoft Unified Communications Managed API 2.0 Core Redist or Microsoft Office Communications Server 2007, Unified Communications Managed API v1.0 Redist when you install one of the following products: 
  • Microsoft Office Communications Server 2007 R2 Products
  • Microsoft Office Communications Server 2007 R2, Group Chat Server
  • Microsoft Office Communications Server 2007 R2, Group Chat Compliance Server
  • Microsoft Office Communications Server 2007 Products

This problem occurs when the following condition is true:
  • The server has .NET Framework 2.0 or .NET Framework 3.5 Service Pack 1 (SP1) is installed together with .NET Framework 4.0.
Additionally, you receive one of the following error messages: 
  • When you install Microsoft Office Communications Server 2007 R2 Products, Office Communications Server 2007 R2, Group Chat Server or Office Communications Server 2007 R2, Group Chat Compliance Server:
    Microsoft Office Communications Server 2007 R2, Microsoft Unified Communications Managed API 2.0 Core Redist 64-bit installation requires Microsoft .NET Framework version 3.5. Installation cannot continue.
  • When you install OCS 2007 Office Communications Server 2007 Products: 
    Microsoft Office Communications Server 2007, Unified Communications Managed API v1.0 Redist installation requires Microsoft .NET Framework version 2.0. Installation cannot continue.

Cause

This problem is caused because Unified Communications Managed API 2.0 Core Redist or Unified Communications Managed API v1.0 Redist detects that a later version of .NET Framework is already installed.

Resolution

To resolve this problem, follow these steps:
  1. Remove .NET Framework 4.0 from the server. 
  2. Install the following products that you want to have on the server:
    • Microsoft Office Communications Server 2007 R2 Products
    • Microsoft Office Communications Server 2007 R2, Group Chat Server
    • Microsoft Office Communications Server 2007 R2, Group Chat Compliance Server
    • Microsoft Office Communications Server 2007 Products
  3. Install .NET Framework 4.0 on the server.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

Another error message may be generated when you install a new member server. This problem occurs when the member server has only .NET Framework 4.0 installed.

The Unified Communications Managed API 2.0 Core Redist Windows installer programs expect that .NET Framework 3.5 SP1 is installed. The Unified Communications Managed API v1.0 Redist Windows installer programs expect that .NET Framework 2.0 is installed.

For more information about .NET Framework 4.0, visit the following Microsoft website:
Properties

Article ID: 2224981 - Last Review: Aug 26, 2010 - Revision: 1

Feedback