E-mail to external recipients with the same e-mail domain causes NDR messages when using the POP3 Connector on Microsoft Windows Small Business Server 2008.

Applies to: Windows Small Business Server 2008 StandardWindows Small Business Server 2008 Premium

Symptoms


Consider the following scenario where you are using the POP3 connector on a Microsoft Windows Small Business Server 2008-based computer running Microsoft Exchange 2007.

You are retrieving emails from the ISP’s POP3 server for the domain: @contoso.com. Once downloaded these mails are delivered locally to the users who have their mailboxes on the Exchange Server.

There also exists a set of users who use the same domain name, but are not a part of your organization and do not have mailboxes on the SBS Server.

They retrieve emails directly from the ISP’s server, using their email client.




For example, if a user on the local network with the e-mail address User1@contoso.com sends mail to an external recipient with the e-mail address User2@contoso.com, Microsoft Exchange 2007 Server returns a Non Delivery Report (NDR) message with details that are similar to the following:

Your message did not reach some or all of the intended recipients.

The e-mail account does not exist at the organization this message was sent to. Check the e-mail address, or contact the recipient directly to find out the correct address.

<FQDN of the SBS Server #5.1.1>

Cause


This behavior occurs when contoso.com is defined as an “Authoritative domain” on the Exchange Server. Exchange server considers itself responsible for delivery of all the mails sent to @contoso.com. When it cannot locate a mailbox for User2@contoso.com it generates an NDR as described in the “Symptoms” section.

Resolution


In order to resolve this issue, you need to change the “Accepted Domain” type to Non-authoritative (Internal Relay) and create a corresponding Send Connector. In case of an Internal Relay Domain, when the server does not find a mailbox locally, the message is routed to the Send connector that has the closest address space match.

Step 1: Change the Accepted domain type from Authoritative to Internal Relay:

1.     Click Start, point to All Programs, point to Microsoft Exchange Server 2007, right click Exchange Management Console, and then click Run as Administrator.

2.     In the Exchange Management Console, expand Organization Configuration and then click Hub Transport.

3.     Click the Accepted Domains tab. This displays a list of domains that your Exchange server receives mails for.

4.     Locate the domain for which you are experiencing the issue, (In this example: contoso.com), select Remove from the Actions pane on the right hand side. Click Yes on the Warning.

** If you do not get the option to remove the domain, it is set as a Default Domain. Right click your local domain and click Set as default, after which you can follow step 4.

5.     On the Actions pane, click New Accepted Domain. New Accepted Domain Wizard starts.

6.     In the Name field provide an appropriate name to describe the Domain.

7.     In the Accepted Domain type the domain name (In this example, contoso.com).

8.     Under Accepted domain options select the option that reads: “Internal Relay Domain. Email is relayed to an e-mail server in another Active Directory forest within the organization”.

9.     Click New, confirm that the accepted domain creation task was Completed and then click Finish.

10.  If this is your reply-to address, right click the domain and select Set as Default.



Step 2: Create a Send Connector:

1.     Click Start, point to All Programs, point to Microsoft Exchange Server 2007, right click Exchange Management Console, and then click Run as Administrator.

2.     In the Exchange Management Console, expand Organization Configuration and then click Hub Transport.

3.     Click the Send Connectors tab.

4.     In the Actions pane, click New Send Connector. New Send Connector Wizard starts.

5.     In the Name filed, provide an appropriate name for the Send Connector.

6.     In the “Select the intended use for this Send Connector” field, select Custom. Click Next

7.     On the Address Space screen Click Add. (By Default the Type is SMTP).

8.     In the Address field enter the name of the domain (In this example: contoso.com). Click OK and then click Next.

9.     On the Network Settings screen, ensure that the “Route mail through the following smart hosts” is selected and then click Add.

10.  Provide the IP Address or FQDN, of the ISP’s Mail server. Click OK and then click Next.

11.  Leave the selection on the “Configure smart host authentication settings” to None, unless specified by your ISP. Click Next.

12.  On the Source Server Screen, ensure that the SBS Server is listed. Click Next and then click New.

13.  Confirm that the Send Connector task was Completed and then click Finish.

More Information


More information:

For Microsoft Windows Small Business Server 2003, please refer to the following Knowledge Base article:

E-mail to external recipients with the same e-mail domain causes NDR messages when using the POP3 Connector.

http://support.microsoft.com/kb/300681