You cannot search the Global Address List with Windows Phone 7 when connecting to Exchange Server 2003

Symptoms

When using a Windows Phone 7 device to connect to Exchange Server 2003 using Exchange ActiveSync, you are unable to resolve user names within your Global Address List (GAL). 

When creating a new e-mail message, you type the name or alias of an e-mail recipient in your organization's GAL in the TO field and the name is not resolved.  In addition, you are unable to Search the GAL, and can only search local Contacts.

Cause

This issue has been fixed in the Windows Phone 7 update 7.0.7390.0, released in March 2011. 

Resolution

Install the latest updates for your Windows Phone 7 device.  For information on updating your Windows Phone 7 device, see the following topic:

How do I update my phone software?
http://www.microsoft.com/windowsphone/en-us/howto/wp7/basics/how-do-i-update-my-phone-software.aspx

Prior to the update, the workaround was to address recipients with a complete e-mail address such as user@contoso.com.

More Information

For additional information on Windows Phone 7 updates, see the following topics:

Windows Phone 7 Updates
http://www.microsoft.com/windowsphone/en-us/howto/wp7/new-features.aspx
 
Windows Phone 7 Updates History
http://www.microsoft.com/windowsphone/en-us/howto/wp7/basics/update-history.aspx

Properties

Article ID: 2463128 - Last Review: Jun 15, 2011 - Revision: 1

Feedback