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Symptoms

Consider the following scenario:

  • You install the Remote Desktop Session Host role service on a computer that is running Windows Server 2008 R2.

  • You enable the following Group Policy settings on the computer:

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security\Required secure RPC communication

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security\Set client connection encryption level

  • The Group Policy settings are refreshed by using one of the following methods:

    • You manually update the Group Policy settings by running the gpupdate /force command.

    • The Group Policy settings are automatically refreshed every 90 minute.

In this scenario, the Remote Desktop service crashes. Therefore, all remote desktop connections on the server are lost, and the data in these sessions may be lost.

Additionally, the following events are added to the System log and to the Application log:


Cause

This issue occurs because the Remote Desktop service does not correctly reload the Winsta.dll module every time Group Policy settings are refreshed.

When the Group Policy settings are refreshed, the Remote Desktop service restarts to load the Group Policy changes. When the service restarts, it unloads and then reloads the Winsta.dll module. However, the service does not reload the Winsta.dll module correctly. Therefore, the Remote Desktop service crashes when a function in the Winsta.dll module is called. 

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have the Remote Desktop Session Host role service installed.

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760
    0.20xxx

    Windows Server 2008 R2

    RTM

    LDR

    6.1.760
    1.21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Termsrv.dll

6.1.7600.20890

711,168

28-Jan-2011

06:17

x64

Termsrv.dll

6.1.7601.21650

680,960

28-Jan-2011

06:24

x64

Workaround

To work around this issue, disable the following Group Policy settings on the computer:

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security\Required secure RPC communication

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security\Set client connection encryption level

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_613bf3192aa6e7ef927fef0fad4acd54_31bf3856ad364e35_6.1.7600.20890_none_c53d9a1c07c4e387.manifest

File version

Not applicable

File size

1,106

Date (UTC)

28-Jan-2011

Time (UTC)

15:15

Platform

Not applicable

File name

Amd64_f3e5b7a7a1ff5bc383d04e0d9e2b5c51_31bf3856ad364e35_6.1.7601.21650_none_32b4a86ea8dd8a45.manifest

File version

Not applicable

File size

1,106

Date (UTC)

28-Jan-2011

Time (UTC)

15:15

Platform

Not applicable

File name

Amd64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7600.20890_none_eb0e0674871f4fad.manifest

File version

Not applicable

File size

29,203

Date (UTC)

28-Jan-2011

Time (UTC)

06:48

Platform

Not applicable

File name

Amd64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7601.21650_none_ed1fa32a84254bd5.manifest

File version

Not applicable

File size

29,749

Date (UTC)

28-Jan-2011

Time (UTC)

06:58

Platform

Not applicable

File name

Update.mum

File version

Not applicable

File size

2,762

Date (UTC)

28-Jan-2011

Time (UTC)

15:15

Platform

Not applicable

File name

Wow64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7600.20890_none_f562b0c6bb8011a8.manifest

File version

Not applicable

File size

10,688

Date (UTC)

28-Jan-2011

Time (UTC)

05:46

Platform

Not applicable

File name

Wow64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7601.21650_none_f7744d7cb8860dd0.manifest

File version

Not applicable

File size

11,234

Date (UTC)

28-Jan-2011

Time (UTC)

05:50

Platform

Not applicable

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