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Symptoms

Consider the following scenario:

  • You have a mail-enabled public folder in a Microsoft Exchange Server 2010 environment.

  • The public folder has an email message that contains an attachment.

  • You try to forward the email message together with your digital signature.


    Note To do this, follow these steps:

    1. Right-click the email message in the public folder, and then click Forward.

    2. Click the icon in the lower-right corner of the Options group to open the Message Options dialog box.

    3. Click the Security Settings button, and then select Add digital signature to this message in the Security Properties dialog box.

    4. Click OK, and then close the Message Options dialog box.

    5. Click Send.

In this scenario, you may experience one of the following symptoms:

  • If you forward the email message to an external recipient, it is not delivered. Additionally, you receive a non-delivery report (NDR) that contains the following information:


    #550 5.6.0 M2MCVT.StorageError; storage error in content conversion ##

  • If you forward the email message to the same mailbox, or to another mailbox inside the same Exchange organization, the email message is delivered. However, it is corrupted. Additionally, the email message contains an extra attachment.

  • If you forward the email message to an Exchange Server 2003 public folder, the email message is delivered. However, public folder replication fails. Additionally, the following events are logged in the Application log:


Note You cannot move the mailbox to another Exchange server when these issues occur.

Cause

These issues occur because Exchange Server 2010 incorrectly returns False to the Outlook client query for the existing attachment in the scenario that is described in the "Symptoms" section. This causes the attachment to be attached two times.

Resolution

To resolve this issue, install the following update rollup:

2529939 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 1

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

There is a Knowledge Base (KB) article that describes similar issues that occur in different scenarios. To view this article, click the following article number:

2469341 Various issues occur after you forward a signed email message by using Outlook in online mode in an Exchange Server 2010 environment

For more information about public folders, visit the following Microsoft website:

General information about public foldersFor more information about how to digitally sign an email message, visit the following Microsoft website:

How to digitally sign an email message

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