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Symptoms

If you try to export or import a mailbox by using New-MailboxExportRequest or New-MailboxImportRequest in Exchange Server 2010 with Service Pack 1, or a later version, the request might time out, and you might receive the following error message:

[PS] New-MailboxExportRequest -Mailbox "<mailbox_name>" -FilePath \\<server_name>\<share>\<file_name>.pst


The call to "net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService <server_name> (14.1.218.11 caps:07)" timed out.

Error details: This request operation sent to net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService did not receive a reply within the configured timeout (00:01:00). The time allocated to this operation may have been a part of a longer time-out. This may be because the service is still processing the operation or because the service was unable to send a reply message. Consider increasing the operation time-out (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and make sure that the service can connect to the client.

+ CategoryInfo : NotSpecified: (0:Int32) [New-MailboxExportRequest], TimeoutErrorTransientException
+ FullyQualifiedErrorId : 59EDFA88,Microsoft.Exchange.Management.RecipientTasks.NewMailboxExportRequest

Cause

You may encounter this problem if a client access array was set up, and a load balancer is being used. When the Exchange server tries to log on to the mailbox for which the import/export was requested, the server will connect to the MoMT endpoint (RPC client access server) for the database, which in most cases will be the CAS array name. If the load balancer is configured incorrectly to enable connections from the Exchange servers to the VIP that the CAS Array resolves to, this results in resets being issued by the load balancer, which will cause the time-out errors listed in "Symptoms."

Resolution

Make sure that the Exchange servers can connect to the load balancer as clients.

In addition, the following workarounds have been documented to allow the move request to be submitted. These workarounds can be implemented if client connectivity from the Exchange servers to the load balancer is not enabled or is not possible.

  • You can change the value of the RPCClientAccessServer on the database that contains the mailbox that you want to import or export to point to a specific CAS server instead of pointing to the CAS array that will use the load balancer. This is a dynamic setting that can be changed as necessary.

  • You can use the -MRSServer switch in the New-MailboxExportRequest or New-MailboxImportRequest cmdlet and specify a CAS server that is not part of the CAS array.

  • You can add an entry to the Hosts file on one or more CAS servers that resolves the CAS array name to the localhost.


More Information

When a mailbox import or export request is submitted, there are several steps to this process. Overall, it is very similar to the Move Request process. The basic process includes the following steps:

  1. The Exchange server to which your Remote Powershell session is connected creates the export/import request. As part of validation that is performed during the creation stage, this Exchange server will connect to the MoMT endpoint and try to log on (through MAPI.Net) to the mailbox into which you are trying to export or to import. If the validation succeeds, a special FAI message will then be put in the System mailbox of the database that contains the mailbox to be exported or imported. The request will be put into "Queued" status.

    Note This is the step that fails with the error as described earlier, and so the request is never created and never put into the System mailbox.

  2. All MRS instances within the same Active Directory site periodically check that mailbox. If no MRSServer is specified in the command, one will be randomly selected. If a specific MRSServer is designated in the command, that MRS instance will be used.

  3. MRS begins the export (or import) and, when it is finished, changes the request to status "Completed."

  4. Optionally, the export or import request can then be cleared by an administrator.


See the following TechNet article for more information about Import and Export requests:

http://technet.microsoft.com/en-us/library/ee633455.aspx

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