Symptoms
When connecting remotely from a Windows 7 machine to a Windows Server 2008 R2 print server and attempting to use the Printer Management snap-in, no printers may appear in the Printer Management Console.
Cause
This can occur if the client system does not have a DNS 'A' record (forward lookup) configured.
Resolution
Add a DNS 'A' record for the system that is running the Printer Management Console.