When a user offers a Remote Assistance invitation to an expert user who is running Windows Server 2003 Service Pack 2, the expert’s logon attempt forcibly logs off the original user

Applies to: Microsoft Windows Server 2003 Service Pack 2

Symptoms


Consider the following scenario:  

  • In a network, a user offers a Remote Assistance invitation to an expert user. Or, an expert user tries to establish a Remote Assistance session by using an invitation file to connect to a user's computer.
  •  The expert is running Windows Server 2003 Service Pack 2(SP2).
  • When the expert receives the invitation and initializes the session, he or she is prompted for user credentials.

However, when the expert enters the credentials, the user is forcibly logged off.

Cause


This problem can occur when the following conditions are true:

1. There are multiple network interfaces in the user's computer.
2. The network connection for the Remote Assistance session is not the first network interface in the binding order.


Resolution


To resolve this issue, remove any IP addresses that are not reachable by the server. To do this, carry out the following steps:

1. Use notepad.exe to open the Invitation file sent to you by the novice user. 
2. Find the RCTICKET portion of the UPLOADDATA section.
3. There will be multiple addresses in the format 1.2.3.4:3389 contained in this section - delete all those that are inaccessible to the server.
4. Save the Invitation file, then double-click it to launch RemoteAssistance on the server and initiate the session as you normally would.