Symptoms
Consider the following scenario in a Microsoft Forefront Threat Management Gateway (TMG) 2010 environment:
- You have an outgoing web proxy server that has anti-malware inspection enabled.
- The proxy server receives a client request HTML object from a slow web server.
- TMG uses the standard trickling delivery method to deliver the inspected object to the client.
Cause
This issue occurs because of a problem in the TMG content delivery method when it handles content from an external web server that has slow bandwidth.
Resolution
To resolve this issue, install the software update that is described in the following Microsoft Knowledge Base article:
2517957 Software Update 1 Rollup 4 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 1
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about the malware inspection delivery method, visit the following Microsoft TechNet website:The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
References
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates