EWS applications cannot connect to Exchange Server 2007 servers after you make changes on accepted domains


Symptoms


Consider the following scenario:
  • In a Microsoft Exchange Server 2007 environment, you have lots of accepted domains (15000 or more). 
  • You make changes to some accepted domains.
In this scenario, Exchange Web Services (EWS) applications cannot connect to the Exchange Server 2007 servers. For example, Outlook for Mac 2011 users cannot connect to the Exchange Server 2007 servers. Additionally, the users receive one of the following error messages:
  • HTTP Resource Not Found
  • Post Data too large

Cause


This issue occurs because the whole accepted domain cache is reloaded from Active Directory directory service when you make changes on accepted domains. During this time, the accepted domain cache is locked to EWS requests.

Resolution


To resolve this issue, install the following update rollup:
2509911 Description of Update Rollup 4 for Exchange Server 2007 Service Pack 3

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about how to create accepted domains, visit the following Microsoft website:For more information about accepted domains, visit the following Microsoft website: