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This article applies to Microsoft Dynamics NAV for all countries and all language locales.

Symptoms

When you run the Business Analytics (BA) Configurator on a native database in Microsoft Dynamics NAV 2009 Service Pack 1 (SP1), the default value in the MaxColSupport property of the Microsoft Dynamics NAV Open Database Connectivity (NODBC) Data Source Name (DSN) is set to blank at the start of the BA Configurator process. In this situation, the default value of 255 is used for the MaxColSupport property. Therefore, the BA cannot access a table that contains more than 255 columns by using the NODBC DSN. However, the NODBC driver can handle tables that have more columns than 255 columns if the MaxColSupport property of the NODBC DSN is set to a bigger number.
For more information about how to set the MaxColSupport property of the NODBC DSN to a bigger number manually, click the following article number to view the article in the Microsoft Knowledge Base:

935330 Error message when you open a table that contains more than 255 fields in Microsoft Dynamics NAV by using Navision Open Database Connectivity (N/ODBC) driver 4.0: "Too many columns. Some columns are omitted" However, the value in the MaxColSupport property cannot be set manually for the NODBC DSN that is built for the BA. The BA Configurator resets the value in the MaxColSupport property of the BA NODBC DSN with a blank value every time that you run the BA Configurator.

Cause

This problem occurs because the following NODBC property values are reset to blank when the BA Configurartor starts:

  • HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\BA0\MaxColSupport

  • HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\BA1\MaxColSupport

Note The NODBC properties are stored in the following instead in 64 bits system:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\BA0\MaxColSupport

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\BA0\MaxColSupport

When the property values are set to blank, the default value of 255 is used for the MaxColSupport property.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website:

https://mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

Partners

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsCustomers

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. Then, you must provide the password provided in the e-mail.


If you click Cancel, the download process stops.


How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing files with the hotfix or the update files for the BA Configurator.

Business Analytics Configurator 4.0.0.33 (SQL Server 2008 Edition)

File name

File version

File size

Date

Time

Platform

Cfront.dll

5.0.0.23963

1,095,120

07-Jun-2007

16:59

x86

Configurator.exe

4.0.0.33

234,544

22-Mar-2011

16:28

x86

Baconfigurator.xml

Not applicable

216

02-Dec-2007

21:45

Not applicable

Customssistasks.msi

Not applicable

650,240

22-Mar-2011

16:28

Not applicable

Language.xml

Not applicable

259,122

12-May-2009

18:07

Not applicable

Languages.xml

Not applicable

4,524

03-Aug-2009

17:31

Not applicable

Business Analytics Configurator 3.0.0.288 (SQL Server 2005 Edition)

File name

File version

File size

Date

Time

Platform

Cfront.dll

5.0.0.23963

1,095,120

07-Jun-2007

16:59

x86

Configurator.exe

3.0.0.288

238,640

22-Mar-2011

16:27

x86

Baconfigurator.xml

Not applicable

216

02-Dec-2007

21:45

Not applicable

Customssistasks.msi

Not applicable

650,240

22-Mar-2011

16:27

Not applicable

Language.xml

Not applicable

259,122

30-Mar-2009

23:54

Not applicable

Languages.xml

Not applicable

4,524

03-Aug-2009

17:31

Not applicable

To replace the files, follow these steps.

  1. Identify the folder where the BA Configurator for SQL 2008 is installed (that is the configurator.exe file). There is no standard location for this file but our documentation recommends that these files be created in a subfolder called "BA" in the folder where the Microsoft Dynamics NAV client is installed.

  2. Backup and delete all the contents of the folder that was identified in step 1.

  3. Copy all the contents of folder that is named "Business Analytics Configurator 4.0.0.31 (SQL Server 2008 Edition)" in the hotfix download into the, now empty, folder that was identified in step 1.

After you apply this hotfix, the value in the MaxColSupport property is set to 5000 when you run the BA Configurator.

Prerequisites

You must have Microsoft Dynamics NAV 2009 Service Pack 1 installed to apply this hotfix.

Removal information

You cannot remove this hotfix.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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