When using Outlook Web App to manage Block or Allow Safe Senders in Exchange Control Panel (ECP), when you check (enable) the “Trust e-mail from my contacts” option and click Save you receive the following error:
Junk e-mail validation error. Value: <E-mail Address>
Symptoms
There are more than 1,024 e-mail addresses in the Contacts folder. This exceeds the default Safe Sender list limit.
Cause
To resolve this issue, increase the default Safe Sender list limit of the mailbox. Use the Set-Mailbox command together with the MaxSafeSenders parameter in the Exchange Management Shell.
-
Open the Exchange Management Shell on a client running the administrative tools for Exchange or on an Exchange Server 2010 computer.
-
Type a cmdlet similar to the following. The example doubles the size of the MaxSafeSenders list for User@contoso.com:
set-mailbox User@contoso.com -MaxSafeSenders 2048
Resolution
For more information about the Set-Mailbox command, visit the following Microsoft TechNet Web site:
Set-Mailbox: Exchange 2010 SP1 Help
http://technet.microsoft.com/en-us/library/bb123981.aspx