The Store.exe process crashes on an Exchange Server 2010 mailbox server during Exchange database online maintenance

S’applique à : Exchange Server 2010 EnterpriseExchange Server 2010 Standard

Symptoms


The Store.exe process crashes on a Microsoft Exchange Server 2010 mailbox server during Exchange database online maintenance. Additionally, the following error is logged in the Application log:

Log Name: Application
Source: MSExchange Common
Date: Date
Event ID: 4999
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Computer: Computer

Description: Watson report about to be sent for process id: Process ID, with parameters: E12N, Build Type, Version Number, store.exe, mdbrest.dll, XXXX, c0000005, XXXX, Version Number.ErrorReportingEnabled: False

Cause


This issue occurs because Exchange store does not check for a NULL value of the PR_SUBJECT_PREFIX property for a message item. The NULL value then crashes the Exchange store.

Resolution


To resolve this issue, install the following update rollup:
2645995 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 2

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about the PidTagSubjectPrefix Canonical property, visit the following Microsoft website:
For more information about how to maintain mailbox databases, visit the following Microsoft website: