Japanese DBCS characters are corrupted when you reply to or forward a message

Applies to: Exchange Server 2010 EnterpriseExchange Server 2010 StandardExchange Online

Symptoms


Assume that you're using Microsoft Outlook to either reply to a message or forward a message that's sent from one of the following environments:
  • Microsoft Exchange Server 2013
  • Microsoft Exchange Server 2010 Service Pack 1 (SP1) or Exchange Server 2010 Service Pack 2 (SP2)
  • Microsoft Exchange Online in Office 365
In this situation, Japanese double-byte character set (DBCS) characters that appear in any of the following fields of the message become corrupted:
  • The display name of the sender
  • The display name of the recipients
  • The subject of the message
  • The file name of an attachment
  • The message body
This issue occurs if the field contains single-byte Kana characters.

Note This issue also occurs in posted items in public folders.

Cause


This issue occurs because the value of the PR_INTERNET_CPID MAPI property of the message is stamped as 50222 by Exchange RPC Client Access service or Outlook Web App. Because of a restriction in Outlook, the code page 50222 characters are corrupted.

Resolution


To resolve this issue, use one of the following methods, as appropriate for your situation.

Workaround


To work around this issue, do not use single-byte Kana characters in the ISO-2022-JP encoded message. For example, use UTF-8 encoded characters in the message instead.