Installing Internet Explorer 9 doesn't apply icons or per-user customizations

Warning

The retired, out-of-support Internet Explorer 11 desktop application has been permanently disabled through a Microsoft Edge update on certain versions of Windows 10. For more information, see Internet Explorer 11 desktop app retirement FAQ.

This article provides information about resolving cases that you don't see icons or per-user customizations of Internet Explorer 9.

Original product version:   Internet Explorer 9
Original KB number:   2642824

Symptoms

After installing Internet Explorer 9 with no reboot option, you do not see icons or per-user customizations.

Cause

This problem occurs because a user with Administrator privileges is required to delete the NoIE4StubProcessingregistry keys. These are put in place to ensure there is a reboot before user customizations take place.

Resolution

Do one of the following steps:

  1. To install using Windows Update or Windows Server Update Services (WSUS).
  2. To reboot the machine as part of the installation process.
  3. To delete the following registry keys:
C:\Windows\System32\reg.exe DELETE HKLM\SOFTWARE\Microsoft\Active Setup\Installed Components /v NoIE4StubProcessing /f

C:\Windows\System32\reg.exe DELETE HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce /v NoIE4StubProcessing /f

Note

If you have a current Internet Explorer Administration Kit(IEAK) package installed you should run the following command prior to the Internet Explorer 9 install: Rundll32.exe iedkcs32.dll,BrandCleanInstallStubs

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