ClickOnce Installation Errors with Message - Application cannot be started. Contact the application vendor.

Applies to: .NET Framework 3.5 Service Pack 1

Symptoms


A ClickOnce application can be published successfully however when attempting to install and launch an error message and log show the following:

Message BoxTitle:
Cannot Start Application

Application cannot be started.  Contact the application vendor.
(OK) (Details)
Log Snippet:
ERROR SUMMARY
 Below is a summary of the errors, details of these errors are listed later in the log.
 * An exception occurred while determining trust. Following failure messages were detected:
  + Value does not fall within the expected range.

Cause


When the ampersand special character is used within the folder structure of the published ClickOnce application the installation and launching will fail. Other special characters such as  : \ / ? * < > are blocked by the operating system. Others such as + ` ; { [ } ] # ! @ # $ % ^ ( ) can be used successfuly however it is always advisable not to use any special characters in either file or folder names.

Resolution


Avoid using the "&" ampersand special character in the folder names for ClickOnce published locations.