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Symptoms

When you try to open a knowledge base (KB) for domain management or for other activities in the Data Quality Client in Microsoft SQL Server 2012, you receive the following error message:

A configuration with name 'RecentList:KB:domain\username' already exists in the database.
Message Id: ConfigServiceConfigurationAlreadyExists


Cause

This issue occurs because, although the comparison between the current logged user name and the list of recent user names is case-sensitive, the user name that is stored in an internal list of recent opened knowledge bases is not case-sensitive. 

For example, you follow these steps:

  1. You log on to Windows by using an account that is named "domain\user1" one time.

  2. You use the Data Quality Client successfully.

  3. You log off from Windows and then log on to Windows again by using an account that is named "DOMAIN\USER1."

  4. You try to use the Data Quality Client to open a knowledge base.

The error may occur because of a difference in lowercase and uppercase letters that were used when the user typed their user name to log on to Windows.

Resolution

Cumulative update information

SQL Server 2012

The fix for this issue was first released in Cumulative Update 1. For more information about how to obtain this cumulative update package for SQL Server 2012, click the following article number to view the article in the Microsoft Knowledge Base:

2679368 Cumulative Update package 1 for SQL Server 2012Note Because the builds are cumulative, each new fix release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2012 fix release. We recommend that you consider applying the most recent fix release that contains this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2692828 The SQL Server 2012 builds that were released after SQL Server 2012 was released

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Workaround

To work around this issue, use one of the following methods:

  • Manually delete the entry from the internal table for the affected user. To do this follow these steps:

    1. Run the following statement to verify that entries exist:

      SELECT * FROM DQS_MAIN.dbo.A_CONFIGURATION WHERE NAME like 'RecentList%';
    2. Run the following statement to delete the record for the affected user: 

      DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%<Domainname>\<Username>';

      Or, run the following statement to delete all recent records for all users. (This deletes the list of all recent users in the client.)

      DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%';
  • Use consistent capitalization rules to specify your user account when you log on to the Data Quality Client computer.


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