Visual Studio installation problems occur if Crystal Reports 8 is installed


Symptoms


When you install Microsoft Visual Studio products on a computer that has Crystal Reports version 8 from Business Objects installed, you receive one of the following error messages:



Message 1
setup error 168
Message 2
setup error failed to register d:\program files\common files\designer\ msaddndr.dll
Message 3
setup was not completed successfully, please reinstall
Message 4
Cannot register msxml3.dll
Message 5
DLL Name was unable to register itself in the system registry
Note This series of errors has been found to occur during both the product installation and the application of the product service packs.

Cause


The third-party program, Crystal Reports, has removed registry permissions from the affected keys.

Resolution


You can use the following procedure to resolve this problem:


  1. Start Regedt32.
  2. Browse to each of the following keys:
    HKEY_CLASSES_ROOT\TypeLib\{000204EF-0000-0000-C000-000000000046}\6.0\9\win32

    HKEY_CLASSES_ROOT\TypeLib\{AC0714F2-3D04-11D1-AE7D-00A0C90F26F4}\1.0\0\win32

    HKEY_CLASSES_ROOT\TypeLib

    HKEY_CLASSES_ROOT\Interface

    HKEY_CLASSES_ROOT
  3. Select each key. From the Security menu, click Permissions.
  4. Make sure that the local computer's Administrators group has full control. Also select Allow inheritable permissions from parent to propagate to this object or, on Microsoft Windows NT, Replace permission on existing subkeys.
  5. Click Apply.
  6. Click Run.

More Information


For more information on this problem, see the following article on the Business Objects Web site:

Steps to reproduce the behavior

Install Crystal Reports version 8.0.0.371 or earlier on a computer that is running Microsoft Windows NT 4.0 or Windows 2000. Next, install Microsoft Visual Studio.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

References


For additional information about the registry problems that are caused by Crystal Reports, click the following article number to view the article in the Microsoft Knowledge Base:

272693 0x80004005 ASP error message occurs when you connect to a database after Crystal Reports 8 installation

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

259569 PRB: Installing third-party product breaks Windows 2000 MDAC registry settings

269383 PRB: 'Error accessing the system registry' message when displaying VB/VBA references

266621 PRB: Error "library not registered" with Crystal Reports 8.0