Error message when a user who does not have a mailbox tries to move or delete an item that is in a shared mailbox by using Outlook Web App Premium

Applies to: Microsoft Exchange Server 2010 Service Pack 2Exchange Server 2010 EnterpriseExchange Server 2010 Standard

Symptoms


Consider the following scenario:
  • You create a user account in a child domain of a Microsoft Exchange Server 2010 forest. The forest has Exchange Server 2010 Service Pack 1 (SP1) Update Rollup 3 or a later update rollup installed.
  • The user does not have a mailbox.
  • You grant the user Full Access permission to a shared mailbox in a different domain. 
  • The user logs on to the shared mailbox by using Microsoft Outlook Web App Premium.
  • The user tries to move or delete an item in the shared mailbox. 
In this scenario, the user receives the following error message:
The Mailbox you are trying to access isn't currently available. Please try again in a few minutes.

Cause


This issue occurs because Outlook Web App Premium cannot create a security context if the user does not have a mailbox. When Outlook Web App Premium uses an Exchange Server 2010 Client Access server to redirect the request to another server, Outlook Web App Premium requires a mailbox to create a security context. However, because the user does not have a mailbox, a UserHasNoMailboxException exception is thrown.


Resolution


To resolve this issue, install the following update rollup:
2661854 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 2

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:
2489822 "The Mailbox you are trying to access isn't currently available" error when you use OWA Premium to try to delete an item that is in a shared mailbox