Symptoms
If you are using a custom MAPI solution (for example, an Outlook add-in), the solution may not work because Outlook.exe is not properly registered in the Windows registry.
Note, the actual problem you experience with the custom solution depends on how it uses the Outlook.exe registration information.
Note, the actual problem you experience with the custom solution depends on how it uses the Outlook.exe registration information.
Cause
This problem can occur if Outlook.exe is not registered correctly under the following keys in the Windows registry:

NOTE: The path to Outlook.exe on your computer may vary from the above figure if you installed Office in a non-default location.
- 32-bit versions of Windows
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths - 64-bit versions of Windows
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths

NOTE: The path to Outlook.exe on your computer may vary from the above figure if you installed Office in a non-default location.
Resolution
To resolve this problem, repair your installation of Office using the following steps:
- Windows 7 or Windows Vista
- Exit Outlook.
- Click Start, and then click Control Panel.
- Then, click Programs and Features.
- In the list of installed products, select your Microsoft Office product and then click Change.
- Click Repair, and then click Continue.
- Windows XP
- Exit outlook.
- On the Start menu, point to Settings, and then click Control Panel.
- Double-click Add/Remove Programs.
- In the list of currently installed programs, select your Microsoft Office product and then click Change.
- Click Repair, and then click Continue.