PROBLEM
If a license is not assigned to the user, the mailbox may be disconnected. This can cause potentially irrecoverable data loss.
Additionally, when you view the properties of the shared mailboxes in the Office 365 portal, you may receive the following error message:
CAUSE
This issue occurs if the RemoteRecipientType attribute is set incorrectly. To be able to convert a User mailbox to a Shared mailbox and not have it be converted back to a User mailbox, the RemoteRecipientType attribute must reflect that the mailbox was migrated or that it is a Shared mailbox. If it does not, directory synchronization replicates the attributes to the cloud. Then, Office 365 converts the Shared mailbox to a regular UserMailbox object. If the user isn't licensed and if the 30-day grace period has ended, the mailbox is disconnected and converted to a MailUser object when license reconciliation runs.
RESOLUTION
To resolve this issue, make sure that a remote mailbox is provisioned for the account, and then update the RemoteRecipientType attribute. To do this, follow these steps:
- If the mailbox in Exchange Online is disconnected, temporarily assign a license to the user. This automatically reconnects the mailbox.
- If a remote mailbox doesn't exist for that user, run the following command:
Enable-RemoteMailbox -Identity PrimarySmtpAddress -RemoteRoutingAddress TargetAddressDomain
Note The TargetAddressDomain value represents your coexistence domain (for example, alias@contoso.mail.onmicrosoft.com). - Set the RemoteRecipientType attribute to reflect that the mailbox is a migrated Shared mailbox. To do this, run the following command:
Set-ADUser -Identity ((Get-Recipient PrimarySmtpAddress).samaccountname) -Replace @{msExchRemoteRecipientType=100;msExchRecipientTypeDetails=34359738368}
MORE INFORMATION
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