The Microsoft Exchange RPC Client Access service consumes 100 percent of CPU resources and stops responding on an Exchange Server 2010 Client Access server

Applies to: Exchange Server 2010 EnterpriseExchange Server 2010 Standard

Symptoms


The Microsoft Exchange RPC Client Access service intermittently consumes 100 percent of CPU resources and stops responding on the Microsoft Exchange Server 2010 Client Access server. If you check Task Manager when this issue occurs, you notice that the Microsoft.Exchange.RPCClientAccess.Service.exe process maintains lots of threads (for example, 1,000 threads).

Cause


This issue occurs because the Microsoft Exchange RPC Client Access service incorrectly handles a situation in which a thread is shut down and a new thread is created at the same time. Therefore, the worker threads for the Exchange RPC Client Access service are leaked.

Resolution


To resolve this issue, install the following update rollup:
2706690 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 2

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.