Rendom: Domain Rename fails if there is a domain with & in the netbios name in the forest

Applies to: Windows Server 2008 R2 DatacenterWindows Server 2008 R2 EnterpriseWindows Server 2008 R2 Service Pack 1

Symptoms



You are trying to rename a domain in your forest using the Rendom.exe tool. 

Rendom /upload completes successfully.

Rendom /prepare shows the following error from all DC's "Failed to bind to server %DC NAME% : 1753" 

A network trace taken during the /prepare operation shows that the DC is not listening the the DsaOp RPC interface - the error returned from the DC is EP_S_NOT_REGISTERED.

example traffic:

EPM:Request: ept_map: NDR, DSaop(DRSR) {7C44D7D4-31D5-424C-BD5E-2B3E1F323D22} v1.0, RPC v5, 0.0.0.0:135 (0x87) [DCE endpoint resolution(135)] {MSRPC:143, TCP:142, IPv6:43} 

EPM:Response: ept_map: 0x16C9A0D6 - EP_S_NOT_REGISTERED {MSRPC:143, TCP:142, IPv6:43} 
 

Cause


The problem happens if there is a domain in the forest which has & in the domain name. For example Contoso&X. This does not have to be the domain you are trying to rename, it can be any other domain in the forest. 

This causes Rendom to produce a faulty rename script. Due to this the DsaOp RPC interface is not listening. 

Resolution


To get around the problem you will need to create a new domain with the required name and migrate the objects from the domains instead of renaming the domain.

More Information


For more information on domain rename see Domain Rename Technical Reference on http://technet.microsoft.com/en-us/library/cc786120(v=ws.10).aspx