Symptoms
- When you use Cached Exchange Mode or an Outlook data (.pst) file, you notice performance issues when you perform certain actions.
- You experience decreased performance in Outlook if the Inbox, Calendar, Tasks, Sent Items, and Deleted Items folders contain lots of items.
If you have lots of mail folders, you may experience performance issues such as the following:
- Folders are not displayed correctly, or they take a long time to appear, especially in cached mode.
- If your Outlook profile has shared mailboxes and has caching enabled (Download Shared Folders is selected), folder synchronization issues, performance issues, and other problems occur if the number of shared folders per mailbox exceeds 500, as described in KB 3115602. Additionally, errors are logged in the Sync Issues folder and "9646" events are logged in the Application log.
- In extreme cases, if there are more than 10,000 folders, Outlook is very slow to open. This behavior occurs because it takes a long time to enumerate the folders.
Cause
Outlook 2019, Outlook 2016, Outlook 2013 and Outlook 2010:
500 folders total
Outlook 2007:
500 folders total
Resolution
If you have exceeded the maximum of 500 folders total, reduce the number of mail folders that you have.
If you have folders that exceed the limit for the number of items in an Outlook data (.pst) file or an offline Outlook data (.ost) file, move items from the larger folders to separate or smaller folders in the same mailbox or data file. Optionally, if you have a Microsoft Exchange online archive, you can move items to it.
You can use the Support and Recovery Assistant for Office 365 to diagnose issues that affect Outlook (not only Office 365).
To download and install the tool, go to the following Microsoft website:
Download Microsoft Support and Recovery Assistant for Office 365
In the tool, run the Outlook Diagnostic under the "Advanced Diagnostics" section to determine cause of the performance issue.
More Information
The following articles list Exchange server performance issues that may occur when a mailbox has high item counts and when restricted views are being used. Additionally, the articles explain how the overall client user experience can be affected by these performance issues.
- Exchange Server 2010
Understanding database and log performance factors - Exchange Server 2007
Understanding the performance impact of high item counts and restricted views - Exchange Server 2003
905803 Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server