You cannot set the active DFS folder by using the DFS utility (Dfsutil.exe) in Windows 7 or in Windows Server 2008 R2

Applies to: Windows Server 2008 R2 EnterpriseWindows Server 2008 R2 DatacenterWindows Server 2008 R2 Foundation More

Symptoms


Consider the following scenario:
  • You install the Distributed File System (DFS) Namespace service on a computer that is running Windows Server 2008 R2. 
  • You create a DFS namespace that has two target folders. For example, you create the following DFS namespace and DFS target folders:
    • DFS namespace: \\contoso.com\ns1
    • DFS folder: \\constoso.com\ns1\folder1
    • Folder target 1: \\server1\share\
    • Folder target 2: \\server2\share\folder1\
  • You run the following command on the computer or on a Windows 7-based client computer that has the Distributed File System tools installed to set target folder 2 as the active target:
    dfsutil.exe client property state active \\constoso.com\ns1\folder1 "\\server2\share\folder1"
In this scenario, the command does not set the active target. Additionally, you receive an error message that resembles the following: 
Could not execute the command successfully.
SYSTEM ERROR - There is no DFS name whose entry path matches the input Entry Path.
Note This issue does not occur when you use the following command to set target folder 1, which does not have subfolders, as the active target:
dfsutil.exe client property state active \\constoso.com\ns1\folder1 "\\server1\share\"

Cause


This issue occurs because Windows does not send the full path of the shared folder when you try to set the active target for a DFS namespace. This behavior prevents the DFS utility (Dfsutil.exe) from setting a shared folder that has subfolders as the active target.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1. Additionally, you must have the DFS utility installed on Windows 7-based computers, or the DFS Namespace service installed on Windows Server 2008 R2-based computers.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Workaround


To work around this issue, use the DFS graphical user interface (GUI) to set a target folder that has subfolders as the active target. You can access the DFS GUI in the Properties window of the folder in Windows Explorer.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates