Symptoms
When Microsoft Outlook users try to access public folders in Exchange Server 2013 or Exchange Server 2016, the following dialog box appears:

However, if the users click Ok in this dialog box, they are not connected to the public folder.
Additionally, the users may receive the following error message:

However, if the users click Ok in this dialog box, they are not connected to the public folder.
Additionally, the users may receive the following error message:
Cannot expand the folder. The set of folders cannot be opened. The file C:\Users\<username>\AppData\Local\Microsoft\Outlook\filename.ost is in use and cannot be accessed. Close any application that is using this file, and then try again. You might need to restart your computer.
Cause
This issue occurs because the AutoDiscover service cannot discover the email address that is stamped on the public folder mailbox.
Resolution
To resolve this issue, use one of the following methods:
- Create AutoDiscover-related DNS records for the email address that is stamped on the public folder mailbox. For more information about the Exchange 2010 Autodiscover service, go to the following Microsoft website:
For more information about how to automatically configure user accounts in Outlook 2010, go to the following Microsoft website: - Change the email address of the public folder mailbox to match an email domain that already has published AutoDiscover records.
More Information
The public folder database concept is removed from Exchange Server 2013 and Exchange Server 2016. The public folders are now stored in a new kind of mailbox that is known as the Public Folder mailbox.
The Outlook client depends on information that is returned by the AutoDiscover service to access the Public Folder mailbox.
The following is an example of Public Folder mailbox information that is returned by the AutoDiscover service:
In this example, the Outlook client tries to "AutoDiscover" PFMailbox@contoso.com. However, if the DNS records that are related to Contoso.com are not present, Public Folder access fails.
The Outlook client depends on information that is returned by the AutoDiscover service to access the Public Folder mailbox.
The following is an example of Public Folder mailbox information that is returned by the AutoDiscover service:
<PublicFolderInformation>
<SmtpAddress>PFMailbox@contoso.com</SmtpAddress>
</PublicFolderInformation>
<SmtpAddress>PFMailbox@contoso.com</SmtpAddress>
</PublicFolderInformation>
In this example, the Outlook client tries to "AutoDiscover" PFMailbox@contoso.com. However, if the DNS records that are related to Contoso.com are not present, Public Folder access fails.