Symptoms
When you send an e-mail message in Microsoft Outlook, the message may remain in your Outbox folder as shown in the following figure.

When this problem occurs, the message remains in your Outbox folder until you manually initiate a Send/Receive operation (for example, press F9 or click Send/Receive).
When this problem occurs, the message remains in your Outbox folder until you manually initiate a Send/Receive operation (for example, press F9 or click Send/Receive).
Cause
This problem can occur if the Send immediately when connected option is not enabled, as shown in the following figure from Outlook 2016.

This setting is tied to the following registry data, so this setting can also be configured by an administrator through a modification of the registry.
Note In the above registry key paths, x.0 represents the Outlook version (16.0 = Outlook 2016, Outlook 2019 or Outlook for Office 365, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007, 11.0 = Outlook 2003).

This setting is tied to the following registry data, so this setting can also be configured by an administrator through a modification of the registry.
Key: HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Options\Mail
or
Policy key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Options\Mail
DWORD: Send Mail Immediately
Value: 0
or
Policy key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Options\Mail
DWORD: Send Mail Immediately
Value: 0
Note In the above registry key paths, x.0 represents the Outlook version (16.0 = Outlook 2016, Outlook 2019 or Outlook for Office 365, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007, 11.0 = Outlook 2003).
Resolution
Please use the following steps to re-enable the Send immediately when connected option.
- Outlook 2010 and later verisons
- On the File tab, click Options.
- In the Outlook Options dialog box, click Advanced.
- In the Send and receive section, click to enable Send immediately when connected.
- Click OK.
- Outlook 2007 and Outlook 2003
- On the Tools menu, click Options.
- In the Options dialog box, select the Mail Setup tab.
- In the Send/Receive section, click to enable Send immediately when connected.
- Click OK.