Opportunity line items do not automatically calculate in Microsoft Dynamics CRM Online after applying the December 2012 Service Update

Van toepassing: Microsoft Dynamics CRM 2011

Symptoms


After applying the latest product update to an organization that has been upgraded to the December 2012 Service Update, users notice that Opportunity line items no longer automatically calculate estimated revenue. 

Cause


The default value for the "revenue" two-option set field, isrevenuesystemcalculated, was changed from "System Calculated" to "User Provided". As a result, the estimated revenue field will not automatically calculate.

Resolution


Change the default value for the revenue field (isrevenuesystemcalculated) from "User Provided" to "System Calculated".

1. Click Settings, click Customizations, and then click Customize the System.

2. In the Default Solution, under Components, expand Entities, and then expand Opportunity.

3. Click Fields.

4. Locate and double click on the Revenue field (isrevenuesystemcalculated).

5. Under Type, change the Default Value setting from User Provided to System Calculated.

6. Click Save and Close.

7. In the Default Solution, click Opportunity.

8. Click Publish.