Delayed error message when you try to access a shared folder that no longer exists in Windows

Symptoms

Consider the following scenario:
  • You have a Windows Server 2012-based or Windows Server 2012 R2-based or or Windows Server 2016-based file server that has the Failover Clustering feature installed.
  • You have a Windows 8, Windows 8.1, Windows 10, Windows Server 2012, Windows Server 2012 R2-based, or Windows Server 2016-based Server Message Block (SMB) client computer.
  • You try to access a shared folder that no longer exists.
In this scenario, it takes around 60 seconds for the error message to appear on the screen.

Cause

This issue occurs because the Continuous Availability feature is introduced in Windows Server 2012. The computer can have more time to determine whether a shared folder is available if there is a failover of the shared folder.

This occurs because the client does not know the share type until it has connected to it. For example, if the client tries to connect to a scale-out share, it will not know that the share is a scale-out share until it has connected to it. If the client gives up too early and one or more scale-out nodes are unavailable, the client might receive incorrect information that the share does not exist.

Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To resolve this issue in Windows 8 or Windows Server 2012, install the hotfix that is described in this article on the SMB client computer. This hotfix is also available at Microsoft Update Catalog.

To resolve this issue on a Windows 8.1-based, Windows 10-based, Windows Server 2012 R2-based or Windows Server 2016-based SMB client computer, create a new registry key named DisableCARetryOnInitialConnect and set the value of the registry key to 1 by following these steps:
  1. Swipe in from the right edge of the screen, and then tap Search. Or, if you are using a mouse, point to the lower-right corner of the screen, and then click Search.
  2. In the search box, type regedit, and then tap or click regedit.
    UAC If you are prompted to enter an administrator password, type the password. If you are prompted to provide confirmation, provide confirmation.
  3. Locate and then tap or click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkStation\Parameters
  4. On the Edit menu, point to New, and then tap or click DWORD Value.
  5. Type DisableCARetryOnInitialConnect.
  6. Press and hold or right-click DisableCARetryOnInitialConnect, and then tap or click Modify.
  7. In the Value data box, type 1, and then tap or click OK.
  8. Exit Registry Editor.
After you configure the DisableCARetryOnInitialConnect registry key, the Continuous Availability feature is disabled for the initial Server Message Block (SMB) tree connect command that is run against a share. If you want to enable the Continuous Availability feature, set the value of the registry key to 0.

Hotfix information for Windows 8 and Windows Server 2012

After you install this hotfix on a Windows 8-based or Windows Server 2012-based SMB client computer, a new registry key named DisableCARetryOnInitialConnect will be created, and will have a value of 1. For Windows 8.1 and Windows Server 2012 R2, you have to manually set the new registry key.

Note If you want to disable the functionality of the installed fix on Windows Server 2012, set the value of the DisableCARetryOnInitialConnect registry key to 0.

With this registry entry enabled, the Continuous Availability feature is disabled for the initial SMB tree connect command that is run against each share.

Note The initial SMB tree connect is the very first share connection (SMB TREE CONNECT) toward each share of the continuously available file server after you start the SMB client computer.

After you enable the DisableCARetryOnInitialConnect registry key in Windows 8, Windows 8.1, Windows 10, Windows Server 2012, Windows Server 2012 R2 or Windows Server 2016

After you install the hotfix and configure the DisableCARetryOnInitialConnect registry key, when you connect to a nonexistent share on a continuously available file server (which supports persistent handles) that has no known continuously available shares, the tree connect failure occurs immediately. This behavior resembles the behavior in Windows 7 or Windows Server 2008 R2.

• If a Windows Server 2012 or 2012-R2 or 2016-based server supports continuously available (which means that it has SMB2_GLOBAL_CAP_PERSISTENT_HANDLES capability set in negotiate response), but the server does not have active continuously available shares, the fix will disable the continuously available retry behavior on the first tree connect for each share. 
• If the server has at least one continuously available share that is connected successfully, the fix with DisableCARetryOnInitialConnectwill not be effective afterward. Any later tree connect to other shares on this server will still have the continuously available retry behavior if the share is not present.

• Workaround to make SMB Client use shorter delays when at least one continuously available share is already connected successfully: Create a second File Server resource and host only non-CA shares on the second resource.


Scale-Out File Server for Application Data Overview

https://technet.microsoft.com/en-us/library/hh831349.aspx

section: When to use Scale-Out File Server

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

More Information

For more information about scale-out file server for application data, go to the following Microsoft website: 
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 8 and Windows Server 2012

Additional files for all supported x86-based versions of Windows 8
File propertyValue
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File versionNot applicable
File size701
Date (UTC)06-Mar-2013
Time (UTC)16:44
File nameX86_483828ae891a90e85b6bd08c40a771f8_31bf3856ad364e35_6.2.9200.20654_none_252474263edef0b3.manifest
File versionNot applicable
File size718
Date (UTC)06-Mar-2013
Time (UTC)16:44
File nameX86_microsoft-windows-d..tryoninitialconnect_31bf3856ad364e35_6.2.9200.20654_none_f6247295e1064dbd.manifest
File versionNot applicable
File size764
Date (UTC)06-Mar-2013
Time (UTC)06:02
File nameX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.2.9200.20654_none_883011d77431ebfc.manifest
File versionNot applicable
File size4,096
Date (UTC)06-Mar-2013
Time (UTC)05:50
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
File propertyValue
File nameAmd64_27c361edb8ceb2e99018204303c7c168_31bf3856ad364e35_6.2.9200.20654_none_4b3e4ecd660642d0.manifest
File versionNot applicable
File size722
Date (UTC)06-Mar-2013
Time (UTC)16:46
File nameAmd64_7a4146b36df937a362eed92da4ebabe9_31bf3856ad364e35_6.2.9200.20654_none_b17f23449aa485c8.manifest
File versionNot applicable
File size705
Date (UTC)06-Mar-2013
Time (UTC)16:46
File nameAmd64_microsoft-windows-d..tryoninitialconnect_31bf3856ad364e35_6.2.9200.20654_none_52430e199963bef3.manifest
File versionNot applicable
File size766
Date (UTC)06-Mar-2013
Time (UTC)07:16
File nameAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.2.9200.20654_none_e44ead5b2c8f5d32.manifest
File versionNot applicable
File size4,100
Date (UTC)06-Mar-2013
Time (UTC)07:33
Properties

Article ID: 2820470 - Last Review: Dec 9, 2016 - Revision: 1

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