Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When the Microsoft Host Integration Server Windows Management Instrumentation (WMI) providers are used to monitor systems that are running Microsoft Host Integration Server 2009, an access violation error occurs, and the Wmiprvse.exe process may exit unexpectedly. Additionally, an event that resembles the following is logged in the Application log:


Cause

This problem occurs because the HIS WmiSna (Wmisna.dll) and HIS WmiSnaStatus (Wmisnastatus.dll) providers are loaded in the same instance of Wmiprvse.exe. When the WmiSnaStatus provider is unloaded from memory, it cleans up some objects that the WmiSna provider also uses. The access violation occurs when the WmiSna provider tries to access one of the objects that were cleaned up when WmiSnaStatus was unloaded from memory.

Resolution

Cumulative update information

The fix that resolves this issue is included in cumulative update package 5 for Host Integration Server 2009. For more information about how to obtain this cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2814103 Cumulative update package 5 for Host Integration Server 2009

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Host Integration Server 2009 Cumulative Update 4 installed to apply this hotfix.

Restart information

You may have to restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace any previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For Microsoft Host Integration Server 2009, 32-bit edition

File name

File version

File size

Date

Time

Platform

Wmisnastatus_xp.mof

Not applicable

24,819

19-Mar-2013

01:19

Not applicable

Wmisna_xp.mof

Not applicable

90,875

19-Mar-2013

01:19

Not applicable

For Microsoft Host Integration Server 2009, 64-bit edition

File name

File version

File size

Date

Time

Platform

Wmisnastatus_xp.mof

Not applicable

24,819

19-Mar-2013

01:19

Not applicable

Wmisna_xp.mof

Not applicable

90,875

19-Mar-2013

01:19

Not applicable

Wmisnastatus_xp.mof

Not applicable

24,819

19-Mar-2013

01:19

Not applicable

Wmisna_xp.mof

Not applicable

90,875

19-Mar-2013

01:19

Not applicable

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.



Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

After you apply this update, the HIS WmiSna (Wmisna.dll) and HIS WmiSnaStatus (Wmisnastatus.dll) providers are loaded into separate instances of Wmiprvse.exe.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×