Secondary dump data is limited to 256 MB in Windows 7 and Windows Server 2008 R2

Applies to: Windows 7 Service Pack 1Windows 7 EnterpriseWindows 7 Home Basic

Symptoms


Consider the following scenario:
  • You have a Windows 7-based or Windows Server 2008 R2-based computer that crashes.
  • A third-party driver uses a Bug Check Callback Routine to include inaccessible memory in the secondary stream.
  • The secondary dump data is very large. For example, the total size is larger than 256 megabytes (MB).
In this scenario, the Bug Check Callback Routines are no longer called as soon as the 256 MB limit is reached.

Cause


This issue occurs because the secondary dump data only allows for 32 MB per chunk and 256 MB overall.

Resolution


After you apply this hotfix, you can use the following DWORD registry value to increase the maximum size to 4 gigabytes (GB) (0xFFFFFFFF):

HKLM\System\CurrentControlSet\Control\CrashControl\MaxSecondaryDataDumpSize
Note Each Bug Check Callback Routine is limited to one-eighth of this value for one or more chunks. To store more than the set limit, register the Bug Check Callback Routine multiple times. The callback order is not defined.

Hotfix information

 A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

More Information


For more information about how to write a bug check callback routine, go to the following Microsoft website:
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates