FAST Search Server 2010 for SharePoint and PowerShell 3.0

Symptoms

The FAST Search Server Administrative cmdlets do not function properly after installing PowerShell 3.0 on the FAST Search Server.

Cause

FAST Search Server 2010 for SharePointsupports PowerShell 2.0 and .NET 3.5 and is not compatible with PowerShell 3.0 or .NET 4.0 as of the time this KB was published.

Resolution

If PowerShell 3.0 is already installed, do not uninstall it as that will cause potential rollback issues.

PowerShell 3.0 supports targeting a previous version, allowing the use of the FAST cmdlets. This can be implemented using the following steps on all servers running FAST Search Server 2010 for SharePoint:
  1. Click Start, and then right-click Microsoft FAST Search Server 2010 for SharePoint.
  2. Click Properties.
  3. Click the Shortcut tab in the Microsoft FAST Search Server 2010 for SharePoint Properties window.
  4. Add -Version 2.0 to the Target field:
    C:\Windows\System32\WindowsPowerShell\v1.0\PowerShell.exe -Version 2.0 -NoExit " & 'C:\FASTSearch\\installer\scripts\shell\FastSearch.ps1' "
  5. Start the Microsoft FAST Search Server 2010 for SharePoint shell and verify that the executed FAST PowerShell is set with the correct version by running
    $host.version
The Major version number should show the value 2
Major
MinorBuild
Revision
20-1-1

The version parameter indicates that PowerShell needs to load the .NET 3.5 Runtime to maintain the supportability and compatibility of FAST Search Server cmdlets.
Properties

Article ID: 2828540 - Last Review: Mar 15, 2013 - Revision: 1

Microsoft FAST Search Server 2010 for SharePoint

Feedback