"0x00000050" Stop error when you try to create a virtual machine or copy a VHD or VHDX file to a SMB share in Windows Server 2012

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

Consider the following scenario:
  • You have the Hyper-V server role installed on a computer that is running Windows Server 2012.
  • You enable performance tracing for the Server Message Block (SMB) server on the Hyper-V server. For example, you run the following command:
    wevtutil set-log Microsoft-Windows-SmbServer/Performance /e:true 
    Note Performance tracing for the SMB server is enabled automatically when you perform certain operations.
  • You configure the Hyper-V server to store Virtual Hard Disk (VHD) or VHDX files for virtual machines on an SMB share. The SMB share is located on a remote computer.
  • You try to create a virtual machine, or you try to copy a VHD or VHDX file to the SMB share.
In this scenario, the remote computer crashes. Additionally, you receive a Stop error message that resembles the following:
STOP: 0x00000050 (parameter1, parameter2, parameter3, parameter4)
Notes
  • This Stop error describes a PAGE_FAULT_IN_NON-PAGED_AREA issue.
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "Stop 0x00000050" errors are caused by this issue.

Cause

This issue occurs because a certain part of the "Event Tracing for Windows" (ETW) feature is enabled. This causes a null dereference to occur when you try to create the virtual machine or copy the VHD or VHDX file to the SMB share.

Resolution

This hotfix is also available at Microsoft Update Catalog

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information
Properties

Article ID: 2834026 - Last Review: Oct 9, 2014 - Revision: 1

Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Datacenter, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Standard, Windows Server 2012 Standard

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