Event ID 15 is logged when you wake a Windows 7 SP1-based or Windows Server 2008 R2 SP1-based computer from sleep mode

Applies to: Windows Server 2008 R2 Service Pack 1Windows Server 2008 R2 EnterpriseWindows Server 2008 R2 Datacenter More

Symptoms


Consider the following scenario:
  • You use an Infineon Trusted Platform Module (TPM) chip on a computer that is running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.
  • The TPM chip is running on firmware TPM 3.19 or later versions. 
  • You put the computer into sleep mode, and then you wake the computer from sleep mode.  
In this scenario, the following event is logged in the System log:

Cause


This issue occurs because in order to meet the Windows 8 performance requirements, the firmware for TPM chip is changed to firmware version 3.19 or later versions. When the computer wakes from sleep mode, the status of the TPM chip is "TPM_DOING_SELFTEST". During this time, TPM may respond to various commands. This results in the event being logged on a Windows 7 SP1-based or Windows Server 2008 R2 SP1-based computer.

Note After you install the hotfix, TPM driver for Windows 7 and for Windows Server 2008 R2 is updated, and the event is not logged.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.