You cannot add VHD files to Hyper-V virtual machines in Windows Server 2012

Applies to: Windows Server 2012 DatacenterWindows Server 2012 DatacenterWindows Server 2012 Standard More

Symptoms


Consider the following scenario:
  • You create some failover cluster nodes on computers that are running Windows Server 2012.
  • You have the Hyper-V server role installed on the cluster nodes.
  • You create virtual machines on one cluster node, and you configure the virtual machines as cluster resources.
  • You create multiple Cluster Shared Volume (CSV) resources and create one Virtual Hard Disk (VHD) file in each CSV.
  • You use Hyper-V Manager to try to add the VHD files to the virtual machines.
In this scenario, you cannot add the VHD files to the virtual machines. Additionally, you receive an error message that resembles the following:
Error applying Hard Drive changes

'Virtual machine' failed to add resources to 'virtual machine'

Cannot add 'C:\ClusterStorage\Volume3\Test3.vhdx'. The disk is already connected to the virtual machine 'virtual machine'. (Virtual machine ID virtual machine ID)

'Virtual machine' failed to add resources. (Virtual machine ID virtual machine ID)

Cannot add 'C:\ClusterStorage\Volume3\Test3.vhdx'. The disk is already connected to the virtual machine 'virtual machine'. (Virtual machine ID virtual machine ID)

Cause


This issue occurs because multiple CSV volumes have the same 0000-0000 serial number. Therefore, the VHD files on different volumes are recognized as the same file.

Resolution


This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.


Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_be7068658c4f7bb9f0655692a7334a23_31bf3856ad364e35_6.2.9200.20686_none_c24c32857537737b.manifest
File versionNot applicable
File size718
Date (UTC)12-Apr-2013
Time (UTC)22:57
PlatformNot applicable
File nameAmd64_microsoft-windows-f..rcluster-csvfs-core_31bf3856ad364e35_6.2.9200.20686_none_2f8c1ecf024dcaff.manifest
File versionNot applicable
File size3,087
Date (UTC)12-Apr-2013
Time (UTC)01:17
PlatformNot applicable