Can't connect to an IEEE802.1X authenticated network after a computer resumes from sleep or hibernation in Windows 7 SP1 or Windows Server 2008 R2 SP1

Applies to: Windows 7 Service Pack 1Windows 7 EnterpriseWindows 7 Home Premium

Symptoms


Assume that a Windows 7 Service Pack 1 (SP1)-based or a Windows Server 2008 R2 SP1-based computer resumes from sleep or hibernation in an IEEE802.1X authenticated network. In this situation, the computer may not obtain an IP address, and you cannot connect to network.

Cause


This issue occurs because new WMI events are dropped after the WMI event queue for size 0x1000 becomes full. Therefore, the components and services dependent on these new WMI events do not function as expected.

Note Because of the event are dropped, the Wired AutoConfig service (dot3svc) cannot detect a wired network connection. Additionally, the computer does not obtain an IP address.

Resolution


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1. For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the update in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this update.

Update replacement information

This update does not replace a previously released update.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information